Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  1. Copy the redistributables directory and all its subdirectories, which contain the EditLive! for Java source files and libraries, to the relevant Web project directory so that the redistributables directory is a sub directory within the Web project.
  2. Open the Solution Explorer window by selecting the View > Solution Explorer menu item.
  3. Once the Solution Explorer window is open select the Project > Show All Files menu item to reveal all the files within the Web project's directories.
    Note: If the Show All Files option is already selected before performing this step it may have to be unselected and then reselected.
    (INSERT IMAGE HERE) Image Added
  4. In the Solution Explorer select the root directory for the EditLive! for Java source files and libraries which has not yet been included in the project (files which are not included are represented as uncolored icons, as above). In the example above the relevant directory is the redistributables directory.
  5. With the relevant root directory selected (in the above example the redistributables directory) select the Project > Include In Project menu item.
  6. The Solution Explorer window should now have colored representations of the EditLive! for Java source files and libraries. It should look similar to the following figure.
    (INSERT IMAGE HERE) Image Added

Constraints

As EditLive! is an HTML editor, it will need to be able to edit HTML and send HTML text back to the server. This means that the .net request validation functionality will need to be disabled through setting the property validateRequest="false" in the page (through the Page directive: <%@ Page validateRequest="false" ...%>).

...