Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  1. In the Microsoft Visual Studio .NET IDE select the Tools > Customize Toolbox... menu item.
  2. Select the .NET Framework Components tab of the Customize Toolbox dialog.
  3. Click Browse...
  4. Browse to the location of the EditLiveJavaControl.dll file. This file can be found in the EditLiveControl_INSTALL/webfolder/aspnet/servercontrol/ directory, where EditLiveControl_INSTALL represents the location you installed the control to.
  5. With the EditLiveJavaControl.dll file selected, click Open.
  6. Ensure that the EditLiveJava control is now available in the list of .NET Framework Components and that the box next to the name of the control is checked.
  7. Click OK.
  8. The EditLive! for Java Server Control should now be available as part of the Microsoft Visual Studio .NET Toolbox.

When using the EditLive! for Java Server Control via the Microsoft Visual Studio .NET Toolbox, the relevant reference will automatically be added to the project when the first instance of the EditLive! for Java Server Control is created.

...

  1. In the Microsoft Visual Studio .NET IDE select the Project > Add Reference... menu item.
  2. Select the .NET tab of the Add Reference dialog.
  3. Click Browse...
  4. Browse to the location of the EditLiveJavaControl.dll file. This file can be found in the EditLiveControl_INSTALL/webfolder/aspnet/servercontrol/ directory, where EditLiveControl_INSTALL represents the location you installed the SDK to.
  5. With the EditLiveJavaControl.dll file selected, click Open.
  6. Ensure that the EditLiveJavaControl.dll file appears in the Selected Components list.
  7. Click OK.

...

  1. Copy the redistributables directory and all its subdirectories, which contain the EditLive! for Java source files and libraries, to the relevant Web project directory so that the redistributables directory is a sub directory within the Web project.
  2. Open the Solution Explorer window by selecting the View > Solution Explorer menu item.
  3. Once the Solution Explorer window is open select the Project > Show All Files menu item to reveal all the files within the Web project's directories.
    Note: If the Show All Files option is already selected before performing this step it may have to be unselected and then reselected.
    (INSERT IMAGE HERE)
  4. In the Solution Explorer select the root directory for the EditLive! for Java source files and libraries which has not yet been included in the project (files which are not included are represented as uncolored icons, as above). In the example above the relevant directory is the redistributables directory.
  5. With the relevant root directory selected (in the above example the redistributables directory) select the Project > Include In Project menu item.
  6. The Solution Explorer window should now have colored representations of the EditLive! for Java source files and libraries. It should look similar to the following figure.
    (INSERT IMAGE HERE)

...

As EditLive! is an HTML editor, it will need to be able to edit HTML , and send HTML text back to the server. This means that the .net request validation functionality will need to be disabled through setting the property validateRequest="false" in the page (through the Page directive: <%@ Page validateRequest="false" ...%>).

...