Page tree
Skip to end of metadata
Go to start of metadata

Client Requirements

Java Version Support

Java 8 is supported in EditLive 9.1 and later. We recommend using the latest release of Java 8.
Java 8 is not supported on EditLive 8 and 9.0. For these releases, we recommend using the latest release of Java 7.

If using Java 6, we recommend using the latest public release (6u45), or upgrading to Java 7 or 8.
If using Java 7, we recommend using the latest public release (7u80). A minimum of Java 7u4 is required.

EditLive requires Oracle's distribution of Java. Other runtimes such as OpenJDK are not supported.

Google Chrome Support

Google has discontinued support for Java in Chrome. See this article for more details.

Firefox for Windows 64-bit Version Support

Firefox for Windows started publishing 64-bit builds as of Firefox 43. These 64-bit builds do not support Java. Please use 32-bit Firefox for Windows.

Note that Firefox 64-bit for Linux does support Java.

Microsoft Windows 8.1, 8, 7, Vista, XP, Server 2008:
  • Oracle Java Runtime Environment 6, 7 or 8
  • Internet Explorer 7+ (IE 11 recommended)
  • Firefox 22-51 (Firefox 52+ no longer supports Java) (32-bit version only)
Apple Mac OS X 10.7+:
  • Oracle Java Runtime Environment 7 or 8
  • Safari 6+
  • Firefox 22-51 (Firefox 52+ no longer supports Java)
Apple Mac OSX 10.6:
  • Java Runtime Environment 6 update 5 or later (supplied by Apple)
  • Safari 5.1+
  • Firefox 22-51 (Firefox 52+ no longer supports Java)
Linux:
  • Oracle Java Runtime Environment 6, 7, 8
  • Firefox 22-51 (Firefox 52+ no longer supports Java)
  • Ubuntu or Linux Mint recommended
EditLive! Microsoft Word Import Feature:
  • Microsoft Windows 8.1, 8, 7, Vista, XP
  • Microsoft Office 2000 or greater installed on the client machine

Supported Application Servers

The EditLive! distribution can be integrated using JavaScript on any web server that HTML content can be served from.

 

  • No labels